Some fixes to Auctioneer for 7.0.3 (Legion) included in this thread
  • I used to code addons in the day so I went ahead and started to fix Auctioneer for 7.0.3. I stopped it erroring on startup and viewing the Auction tab but it still errors when trying to scan, which either I or someone else can take a look at (taking a break). The main culprits were the removals of these functions: GetAuctionItemClasses, GetAuctionInvTypes, FilterButton_SetType, animationGroup:SetChange

    Below are pastebins to the changed files. The devs can use these to fix the code towards a bugfix release. Until then you can replace the code in the files with my code.

    Auc-Advanced/CoreConst.lua: http://pastebin.com/cqXyP5pb
    Auc-Advanced/CoreScan.lua: http://pastebin.com/wFaFZwzF
    Auc-Advanced/Modules/Auc-Util-SearchUI/SearcherGeneral.lua: http://pastebin.com/1yAqvhgf
    Auc-Advanced/Modules/Auc-Util-SearchUI/SearchRealTime.lua: http://pastebin.com/9mT7ATFt
    Auc-Advanced/Modules/Auc-Util-ScanButton/ScanButton.lua: http://pastebin.com/St0y1WT0
    Informat/InfMain.lua: http://pastebin.com/nJS0BbwH

    Note I do see the project members are making active changes (including one commit today) but their source site is so slow today that it was actually faster to fix these bugs myself.
  • Thanks a lot for your help.
  • Thankyou for working on this. I have absolutely no coding experience so I can't help much there, but if you need some help testing in game i'm more than happy to help.
  • Unfortunately it seems the quick fixes I did in an hour did not really make it usable except for Informat =/ I'll try again later today to grab the latest source and see how polished that is.
  • Thanks for posting these thrae, I'll use your Informant fix.

    As you found, though, those Const lookup tables are going to be a lot tougher to rework.
  • not work for me..!!!!
  • Fixing those Const lookup tables is going to take longer than I originally thought. Looks like I'm going to have to dig through Blizzard_AuctionUI code to figure out how to do it.
  • very tanks for you work!!
  • I think you could use this as replacement at Classes (CoreConst row 141)
    http://pastebin.com/p9pNJ4M1

    Those strings are hardcoded into Blizzard_AuctionData.lua beginning at row
    313. From here and downwards it builds the complete categories list "AuctionCategories" Where every Category, subcategory and itemtype is sorted.
    I think the old results to GetAuctionInvTypes is included in that information.
    I'm just not sure about what information that should be gathered :/

    What is "fixed" so far?
  • brykrys

    Thanks for the progress update. If possible, please post back every few days with updates and eta guestements

    You guys create a wonderful addon. As is often the case, its easy to take things for granted until they are no longer available. Yall keep up the good work!
  • also, it may be helpful to publish pre beta releases, even if they are not complete and only bring partial functionality back
  • Thanks man.
  • Seconding KK's comment: Even if "alpha, gonna' break things" level, I'm willing to give works-in-progress a shot and kick back whatever feedback the team would like.
  • Now that we know that the work is being done, as a non-coder I would like to know if I can help. Is funding an issue? I've donated with every new release, and expect to continue to do so. If user donations aren't meeting needs, I'd like to know. Maybe we could get some data such as total expenses, monthly expenses, donations, # of donators, average donation, donation needed per donator, donation needed per user, etc. I personally would like to know if I'm giving my fair share or if I should give more, and, if so, how much.
    I've been using TSM the last few days, but it's not made for the player. It's made for the gold farmer. Auctioneer has been the perfect addon for so many of us for so long. I can't say how relieved I am to hear that the work is continuing. If I can help test, fund, anything, just let me know what's needed.
  • Message: ...uc-Advanced\Modules\Auc-Util-CompactUI\CompactUI.lua line 392:
    attempt to call global 'GetDetailColumnString' (a nil value)

  • Thank you
    Can't be said enough. I'm not sure I'd play wow without Appraiser.
    Toltec
  • Great job on addon over the time, AH is fun with Auctioneer as the guide.
    Where would I send error codes if I do get them? Used the pastebins, still getting a scan error and a scan button error, and I'd love to help with some active feedback.
    Not trying to hurry you guys at all, legion is a while away still, more that I would love to help out, seeing as your addon has made me wowrich <3
  • I appreciate seeing an active community take action instead of yelling at someone to stop what could be a real life situation to fix something for a game. I have been playing since Vanilla. This crap happens every time when a complex addon is in use during a patch, update, or launch of new content for the game. GAME.

    I am newer to coding and have some SQL background so not completely unfamiliar with the concept. I started looking into lua and toc content and design yesterday and would like to help a bit if I can. Anyone with info they could share to help me help the community, I'm all ears and would be very enthused to help. Message me. I will be looking over the latest pastebins to see if I can learn more.
  • Compact UI was broken. Please HELP !!!!
  • Not sure if this will help but it looks like GetAuctionItemClasses has been replaced with the following api functions

    GetItemClassInfo, GetItemSubClassInfo. Also GetItemInfo has 2 new returns itemClassId and itemSubClassId.

    Found this info at https://www.wowinterface.com/forums/showthread.php?t=53248&page=3

  • @brykrys - Yeah I had to dig around and compare the old AuctionUI code to the new AuctionUI and AuctionData code to get my quick fix, which seems didn't work? But it seems the thread paulc74 linked has the best answer.

    As for my own work: I was thinking of cloning the dev channel onto a CurseForge account and as well as working on some independent libraries of my own. I think for compatibility reasons it'd be nice to have a library that can fall back on alternative methods, like hardcoded data, for when global functions are changed or simply disappear. This could (and should) also be done just by coding standard, but it may be nice to make it a lib that provides a working standardized API.

    I also want to try making an independent version of Auc-Util-Appraiser that can use various sources, as I find this is the main reason I use auction addons in the first place.
  • Got things somewhat working by incorporating the fixes from this thread and getting a kludge in for the real problem: QueryAuctionItems() parameters changed.

    https://github.com/greerga/Auctioneer

    Didn't try fixing Enchantrix-Barker and searching by category in the main UI is busted, but it is enough for "Appraiser" to work. "Search" sort of works, but the current code doesn't handle buying when GetItemInfo() doesn't have the item cached, so only some items are purchasable.

    Some bits are more workarounds than "fixes" but I'll leave polish to the authors who know what they're doing. :)
  • GeorgeG , so go to all the first takes and copy the pieces into the according subdirectories in the addon directory? and if wow jumps out of the pc afterwards????
    I dont care as is no fun playing the way it runs now...
  • debbie_t, go to the github link GeorgeG provided, then click "Clone or Download" and select "Download ZIP". Then just do what you would with any other wow addon.

    GeorgeG, thanks for posting that. Truly appreciated.
  • I've discovered that if you hover your mouse over the items in the "Search" tab that you want to buy until the "Retrieving item information" disappears from the tooltip then the purchase in Auctioneer will succeed. This is essentially a manual workaround to cache the information so the API returns the data to Auctioneer immediately, instead of needing a server call and event callback that Auctioneer currently won't.
  • I'm working my way backward from the QueryAuctionItems parameter change, to try to get the scan/buy functions working again.

    At first I thought we might not need the tables in CoreConst at all, but now I think SearchUI will need at least some of them, so I'll grab/merge bits out of some of the files you posted here - thanks! - as I figure out which ones we still need.
  • Didn't know where else to post this, so if it's in the wrong section of the forum, sorry.
    After getting and "installing" Auc-Advanced from https://github.com/greerga/Auctioneer
    the scanning of the AH works fine, for me at least.
    No errors so far.


    Thank you for an otherwise fantastic addon. I've used a it for the majority of 10yrs.
  • @Jaguar
    It does not work for me. The errors continued, but others. When browsing the auction is constantly changing the total number of auctions, items do not correspond to the selected partitions, etc.
  • Brykrys, Thanks for everything you do. Just wanted to let you know that yuo are very appreciated :) I have had to use the stock AH lately *Shudder* and it makes me know how much I rely on this addon
  • And btw, I downloaded the temp fix from George, and it sort of works. now 1 question though.. is it possible to remove the bright green neon colors? Makes seeing the price impossible lol

    http://imgur.com/a/PFQOo
  • Same issue for me as Bigman1182: http://i.imgur.com/RGfvjdo.png

    The frame from mousing over an item keeps shaking left and right in a continues loop. Don't know if that's Auctioneer though, but the issue have only come after getting Auc-advanced from github: http://i.imgur.com/vYNzxYz.png?1

    Also the memory used for Auc-Auctioneer (core) is fairly high as with Auc:Stat:Histogram: http://i.imgur.com/hDuFLzw.png
  • Yes, I have the shaking issue too, havent looked at the mem usage
  • I, too, tried to install Auctioneer from GeorgeG's github. I got the "Auctioneer unable to load: Configurator Babylonian TipHelper" message.

    In my old installation, I have these modules in a "lib" directory in the Auc-advanced, Informant, and Enchantrix directories. The github version has no "lib" directory, but does have an "include" file that names the missing modules.

    Is the github version missing a "lib" directory and should I add it?
  • Step 1) Copy latest "official" release of auctioneer to WoW/Interface/Addons.

    Step 2) Download GeorgeG's ZIP file of his patches https://github.com/greerga/Auctioneer

    Step 3) DO NOT DELETE OFFICIAL AUCTIONEER. Instead, COPY EVERYTHING from GeorgeG's ZIP into WoW/Interface/Addons and allow it to OVERWRITE everything that it wants to.

    Step 4) Profit

    Appraiser is working for me <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3<br />
    (Alt+Click on the "refresh" button within appraiser will manually refresh everything in your bags. Much better than trying to deal with "getall" right now.



    Edit: Beancounter is VERY annoying when trying to get mail. I turned it off.
  • I turned all my addons off on my bank toon and I got a total of 34. It may not sound as much, but with all their folders it mounts to 129.
    Providing link so you can see which I have and I'll point out the ones I use on my bank toon. Have: http://i.imgur.com/41CDVHn.jpg
    Used on Bank toon: All of AtlasLoot, All of Auctioneer (except Enchantrix and Enchantrix-Barker), BadBoy, BankItems, BugGrapper, BugSack, All of Carbonite (except Info, Notes, Quest), Chinchilla Minimap, EasyMail, MiniMap Button Frame+Skin Pack, Reagent Helper 2: Remastered, All of Titan Panel (except Archaeology, Repair, Volume, XP), WIM, Wowhead Looter, ElvUI+ElvUI Config.
    I turned 5 addons on at a time, logged in, tested mouseover and the green stuff mashed out over the inner frame of the Auction Window. I continued logging in and out and turning addons on.
    The culprit for me is Stubby on both counts.

    Without Stubby I don't have Appraiser or any of the other options that Auc-Advanced gives me, and with Stubby the mouseover menu is shaking continously left and right as well as the green stuff in the auction window frame.

    Green Stuff: http://i.imgur.com/RGfvjdo.png

    I know the github download didn't come with Stubby in it's package, but can it really be correct that Stubby has to be turned on for the rest to work?
    And even so, the shaking on mouseover menu if caused by Stubby defo needs a fix. I have no error report to show what happens as neither Bugsack nor BugGrapper gives action.

    Also Beancounter give an error message when my lvl 100 toon that uses Auc-Advanced with Beancounter, when said toon is in it's Garrison checking mail. But doesn't give error on my bank toon that's lvl 1 and located in Undercity.
    Said error is reported in this thread: http://forums.norganna.org/index.php?p=/discussion/comment/1248#Comment_1248
  • Using the instructions below only "SEEMS" to fix the issues....yes it stops the errors..but you are not able to Search items say if you were to search under Armor>Plate>Feet

    Thus, still broken.




    @MrWhite 12:05PM
    Step 1) Copy latest "official" release of auctioneer to WoW/Interface/Addons.

    Step 2) Download GeorgeG's ZIP file of his patches https://github.com/greerga/Auctioneer

    Step 3) DO NOT DELETE OFFICIAL AUCTIONEER. Instead, COPY EVERYTHING from GeorgeG's ZIP into WoW/Interface/Addons and allow it to OVERWRITE everything that it wants to.

    Step 4) Profit

    Appraiser is working for me <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3<br />
    (Alt+Click on the "refresh" button within appraiser will manually refresh everything in your bags. Much better than trying to deal with "getall" right now.



    Edit: Beancounter is VERY annoying when trying to get mail. I turned it off.
  • @DoctorWho

    GeorgeG did say that the main buying might be broken still. For most people it looks like Appraiser is the most important thing needed. I cannot sell hundreds of items with the default AH, auctionator, or TSM efficiently. So, just getting Appriaser going again is a huge help for me.

    I've just been using Auctionator to buy stuff, not as nice as Auctioneer, but still much better than default AH. And it seems like Auctioneer and Auctionator are still playing together nicely right now.
  • I just wanted to say thank you for working on this. I've tried to get into TSM, but I desperately would love to have Auctioneer back and running. It's really spoiled me for AH posting!
  • Mr. White: I version 5.12g, then put George's zip file on top of it, letting windows replace what it wanted. Now I can run Auctioneer and use the parts I want. Thank Youall for that.

    All: I still get some problems, I see the jitter and the bright green columns on the browse page, but it is still usable (I am quite tolerent). I did get an error from BeanCounter about GetInboxItem being nil at BeancounterMail:line182, and an error from Enchantrix-Barker at line183 about GetTradeLineFunc being nil. I'll look into these a see if I can see how the API changed.

    Is there a way to get the current development code, so I don't try to fix something they have done already?

    Thanks!
  • I freely admit that when it comes to coding software, I am a complete luddite. Do it for me; make it work; don't pretend I know where to plug it in. I didn't even realize that three of my favorite WOW addons came from the same source until this week: Auctioneer, Gatherer, and Enchantrix. Now, I can live without the last two, but without my Auctioneer Suite, I don't even want to play the game. It's that lovely appraisal feature, don't you know. So before I tell the credit card company to please cut Blizzard off, could someone please tell me how long I must endure without it?
  • DoctorWho: Blizzard greatly redid how categories are handled by the auction interface so the code Auctioneer uses to read those from the interface doesn't work. I noted that as "searching by category in the main UI is busted".

    The GitHub ZIP differs releases because the Subversion repository isn't laid out the same as the releases. As noted above, copying over top of the release works (although you may want to move the "Auc-Util-*" into "Auc-Advanced/Modules" afterward).

    brykrys has already fixed the BeanCounter error in Subversion.

    Waveletts: Subversion repository is http://svn.norganna.org/auctioneer/trunk and http://svn.norganna.org/libs/trunk

    Also, I suggest looking at the WoW UI Source (ex: https://github.com/Gethe/wow-ui-source) so you can see how official Blizzard add-ons work, including the auction interface.
  • I have the bright green too. I'm assuming it is coming from CompactUI but haven't investigated. There are other color issues too, like the selected item isn't highlighted and the backgrounds don't correspond with the pricing% anymore. This one of the "polish" items that I don't plan to fix myself.

    Also have the shaking, guessing from Informant since if I choose the "embed information into tooltip" (second option in Informant) then the shaking stops. This might annoy me enough to fix; it gives me headaches if I look at it for too long.

    GetAll searches do work for me.
  • "The frame from mousing over an item keeps shaking left and right in a continues loop. Don't know if that's Auctioneer though"

    TSM also has this problem, could be a general problem with custom tooltips.
  • I "fixed" the shaking tooltips with a change to LibExtraTip. That code isn't in the repository I cloned onto GitHub so I'll put it here.

    Index: LibExtraTip/LibExtraTip.lua
    ===================================================================
    --- LibExtraTip/LibExtraTip.lua (revision 403)
    +++ LibExtraTip/LibExtraTip.lua (working copy)
    @@ -1486,8 +1486,10 @@
    end

    local function refresh(self)
    + if self.fresh then return end
    self:NeedsRefresh(false)
    self:MatchSize()
    + self.fresh = true
    end

    Root cause seems to be that other frame logic resizes the window to fit its contents but LibExtraTip tries to make the window match the parent tooltip's width and the two get into a fight. Adding the two lines above will make LibExtraTip only set the size of the window once, avoiding the fighting that causes the shaking.
  • unfortunately it looks that the situation with LibExtraTip is that it is pretty much abandoned and there's no central stable usable reference source anymore and as a consequence the usage and distribution of various LibExtraTip mods is fragmented as hell...

    LibExtraTip.toc says that the "official" source code is at
    http://zip.norganna.org/libs/LibExtraTip/
    BUT, that has last been updated more than 5 years ago :(
    LibExtraTip-latest.zip 23-May-2011 12:42

    TSM uses their own version of LibExtraTip.lua... i think that they basically forked the entire library development and are maintaining it separately for the TSM addons.
  • Just wanted to say a huge thanks to George for his work. As far as I can tell he isn't one of the official authors and thus isn't getting any of the donations that the generous people in the other thread are giving. His fixes and workarounds may not be perfect, but they've at least restored partial functionality.

    With respect to the flickering tooltips, embedding the tooltip in Informant does stop it for me, without having to use the ExtraTip fix.

    Also, as a quick workaround for the green bars when searching, you can use the first Colorblind filter in the Accessibility section of the deafult Blizz Interface Options. Turn it up to 100% while using the AH and it creates enough contrast between the text and that violent shade of green so that you can actually see prices. At least it does for me, ymmv.
  • "local function refresh(self)
    + if self.fresh then return end
    self:NeedsRefresh(false)
    self:MatchSize()
    + self.fresh = true
    end"

    Interesting, problem is to really fix it every mod that uses LibExtraTip needs to be fixed. I wonder why it's behaving badly though. Disabling it fixes the flickering, but then the tooltip sizes don't match.
  • Thanks for your help George. If you are interested in joining the team please drop by the irc channel. It's a quiet place but people respond eventually. Leithien, the donations go towards upkeep of the development server and web server, the developers are all volunteers.
  • Hi,

    Registered to also say thank you, like everyone else here. Since I've started playing a few years back this is the addon I've always used, I just can't find anything that works as well :))

    Since prepatch first thing I do when I get to my pc, I check if there's an update for Auctioneer, I feel a bit lost without it. Installed others, but just isn't the same.

    So I'll keep checking. In the meantime, thank you very much for your work through the years. I see when I look at posts, I'm not the only one that feels lost without it :)
  • I would like to thank all who have helped try and get things working.....it is all very impressive work for those who have provided "fixes" and "edits" etc....but let's face it these are "band-aids" at best...and as clearly stated...it still isn't working fully or properly.

    The main problem here that everyone is not seeing is that the current developers need to come up with the actual releases and fixes...

    I mean look at it this way...they have an entire team working on this...who is supposed to be dedicated to getting things going....yet in a matter of days....random people (fans) have provided more then they themselves?

    Clearly, we love, need and sorely miss our Auctioneer and associated addons...get a move on and get an update out already!
  • @DoctorWho

    "they have an entire team working on this"
    No, they don't. They are all 100% volunteers.

    "get a move on and get an update out already"
    Are you able to pay them their server costs for a year? Or perhaps pay them directly what they make in "real life" to cover the costs of coding it again?

    I don't think you clearly understand the issues. FYI, blizzard banned addons from charging money to download them, ie. Carbonite. So, without random people offering their time for free, there is no "team".

    If I wasn't living on a friends couch doing random small jobs, I would donate $100 or more right now. I did donate $5 from my bank account that had $6 in it. People need to put their money where their mouths are if we want to get this thing back up and running ASAP.

    Please consider donating for the first time, or again. They also have a "subscription" option which would probably give them a reason to fix it every time blizz patches. If any of you have used it for years think of it like a bill. The services have already been rendered, we owe them. Not the other way around.

    Thank you everyone.
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

privacy
norganna's addons network · tf2 warehouse · scrap warehouse · auctioneer addon · gatherer addon · addon forums · rdrct