Auctioneer Post Refresh Bug (CLASSESREV - mix of release and svn folders)
  • Hi, I've been having this bug for a while. I figured it was because I was using the beta version, but now that the official release is out I'm still having it. Help?

    Date: 2016-08-20 16:20:24
    ID: 21
    Error occured in: Global
    Count: 1
    Message: ...nterface\AddOns\Auc-Util-SimpleAuction\SimpFrame.lua line 888:
    attempt to index field 'CLASSESREV' (a nil value)
    Debug:
    ...nterface\AddOns\Auc-Util-SimpleAuction\SimpFrame.lua:888:
    ...nterface\AddOns\Auc-Util-SimpleAuction\SimpFrame.lua:880
    Locals:
    background = {
    0 =
    Text = AucAdvSimpFrameText {
    }
    Right = {
    }
    Middle = {
    }
    Left = {
    }
    }
    name = "Sumptuous Fur"
    minLevel = 0
    typeId = nil
    subtypeId = nil
    quality = nil
    link = "[Sumptuous Fur]"
    itemName = "Sumptuous Fur"
    _ = "[Sumptuous Fur]"
    itemRarity = 1
    _ = 90
    itemMinLevel = 0
    itemType = "Tradeskill"
    itemSubType = "Cloth"
    (*temporary) = nil
    (*temporary) = "Cloth"
    (*temporary) = 200
    (*temporary) = ""
    (*temporary) = 1029741
    (*temporary) = 1750
    (*temporary) = 7
    (*temporary) = 5
    (*temporary) = "attempt to index field 'CLASSESREV' (a nil value)"
    frame = AucAdvSimpFrame {
    0 =
    cache = { } duration = AucAdvSimpFrameDuration { } OnEvent = defined @Interface\AddOns\Auc-Util-SimpleAuction\SimpFrame.lua:1359 buy = { } ClickBagHook = defined @Interface\AddOns\Auc-Util-SimpleAuction\SimpFrame.lua:1150 stacks = AucAdvSimpFrameStacks { } tab = AuctionFrameTabUtilSimple { } list = { } bid = { } info = { } icon = { } imageview = { } fees = { } minprice = AucAdvSimpFrameStart { } options = AucAdvSimpFrameOptions { } slot = { } CurItem = { } refresh = { } create = AucAdvSimpFrameCreate { } scanbutton = AucAdvScanButton { } clear = AucAdvSimpFrameRemember { } config = { } name = { } buyout = AucAdvSimpFrameBuyout { } SetButtonTooltip = defined @Interface\AddOns\Auc-Util-SimpleAuction\SimpFrame.lua:935 err = { } title = { } detail = { }}Const = { ENCHANT = 26 LASTENTRY = 27 IEQUIP = 5 MAXSKILLLEVEL = 800 AMHIGH = 19 AC_ClassNameList = { } FACTOR = 25 MINBID = 15 FLAG_UNSEEN = 2 AucMinTimes = { } FLAG = 21 FLAG_DIRTY = 64 CompactRealm = "ThoriumBrotherhood" AC_PetType2SubClassID = { } ALEVEL_MAX = 5 EquipEncode = { } AC_EquipCode2InvTypeID = { } CANUSE = 13 PlayerName = "Sennef" AC_InvTypeNameList = { } ITEMID = 23 MAXITEMLEVEL = 950 AC_InvTypeIDList = { } AC_SubClassIDLists = { } PlayerRealm = "Thorium Brotherhood" ALEVEL_MED = 3 DEP2 = 10 ISUB = 4 ScanPosLabels = { } MAXUSERLEVEL = 110 ULEVEL = 14 BUYOUT = 17 ALEVEL_HI = 4 AC_ClassIDList = { } ALEVEL_LOW = 2 ITYPE = 3 ALEVEL_MIN = 1 AucTimes = { } NAME = 9 FLAG_EXPIRED = 128 FLAG_CORRUPT = 256 CURBID = 18 MAXBIDPRICE = 99999999999 COUNT = 11 SEED = 27 SUFFIX = 24 AC_SubClassNameLists = { } AC_EquipLoc2InvTypeID = { } SELLER = 20 LINK = 1 ILEVEL = 2 FLAG_FILTER = 4 TIME = 8 TLEFT = 7 BONUSES = 22 AucMaxTimes = { } QUALITY = 12 SUBCLASSID = 4 ALEVEL_OFF = 0 MININC = 16 PRICE = 6 CLASSID = 3}aucPrint = defined @Interface\AddOns\Auc-Advanced\CoreUtil.lua:166StartPushedScan = defined @Interface\AddOns\Auc-Advanced\CoreScan.lua:284PushScan = defined @Interface\AddOns\Auc-Advanced\CoreScan.lua:322StartScan = defined @Interface\AddOns\Auc-Advanced\CoreScan.lua:403AddOns: Swatter, v7.0.5664 (TasmanianThylacine) WowheadLooter, v60014 NPCScan, v7.0.3.7 AdvancedInterfaceOptions, v1.0.5 Archy, v7.0.3.13 AucAdvanced, v7.0.5664 (TasmanianThylacine) AucDb, v5.1.DEV.3583 AucFilterBasic, v7.0.5664 (TasmanianThylacine) AucFilterOutlier, v7.0.5664.5459(7.0/embedded) AucMatchUndercut, v7.0.5664.5585(7.0/embedded) AucScanData, v7.0.5664 (TasmanianThylacine) AucStatDebug, v<%version%> (<%codename%>) AucStatHistogram, v7.0.5664 (TasmanianThylacine) AucStatiLevel, v7.0.5664 (TasmanianThylacine) AucStatPurchased, v7.0.5664 (TasmanianThylacine) AucStatSales, v7.0.5664.5598(7.0/embedded) AucStatSimple, v7.0.5664 (TasmanianThylacine) AucStatStdDev, v7.0.5664 (TasmanianThylacine) AucStatWOWEcon, v7.0.5664.5613(7.0/embedded) AucUtilAHWindowControl, v7.0.5664.5575(7.0/embedded) AucUtilAppraiser, v7.0.5664.5653(7.0/embedded) AucUtilAskPrice, v7.0.5664.5599(7.0/embedded) AucUtilAutoMagic, v7.0.5664.5587(7.0/embedded) AucUtilCompactUI, v7.0.5664.5629(7.0/embedded) AucUtilEasyBuyout, v7.0.5664.5576(7.0/embedded) AucUtilFixAH, v7.0.5664 (TasmanianThylacine) AucUtilGlypher, v<%version%> (<%codename%>) AucUtilGlypherPost, v<%version%> (<%codename%>) AucUtilItemSuggest, v7.0.5664.5651(7.0/embedded) AucUtilPriceLevel, v7.0.5664.5633(7.0/embedded) AucUtilScanButton, v7.0.5664.5631(7.0/embedded) AucUtilScanFinish, v7.0.5664.5588(7.0/embedded) AucUtilScanProgress, v7.0.5664.4979(7.0/embedded) AucUtilScanStart, v7.0.5664.5347(7.0/embedded) AucUtilSearchUI, v7.0.5664.5657(7.0/embedded) AucUtilSimpleAuction, v7.0.5664.5654(7.0/embedded) AucUtilVendMarkup, v7.0.5664.4828(7.0/embedded) Auctionator, v4.0.9 Babylonian, v5.1.DEV.332(/embedded) BeanCounter, v7.0.5664 (TasmanianThylacine) Configator, v5.1.DEV.406(/embedded) DBMCore, v DBMDefaultSkin, v DBMGarrisonInvasions, v DBMStatusBarTimers, v DebugLib, v5.1.DEV.337(/embedded) Enchantrix, v7.0.5664 (TasmanianThylacine) EnchantrixBarker, v7.0.5664 (TasmanianThylacine) HandyNotes, vv1.4.8 HandyNotesAchievements, v0.4.19 HandyNotesLegionRaresTreasures, v0.6 HealBot, v7.0.3.0 HealBotTips, v6.2.3.1 Informant, v7.0.5664 (TasmanianThylacine) LibExtraTip, v5.12.DEV.409(/embedded) MasterPlan, v0.100 MasterPlanA, vA Overachiever, v0.84 Postal, vv3.5.8 sellgrey, v7.0.3.22280 Skada, v1.5-6 SlideBar, v7.0.5664 (TasmanianThylacine) Stubby, v7.0.5664 (TasmanianThylacine) TidyPlates, v6.18.Beta20 TidyPlatesGraphite, v TidyPlatesGrey, v TidyPlatesNeon, v TidyPlatesQuatre, v TidyPlatesHub, v TidyPlatesWidgets, v TipHelper, v5.12.DEV.405(/embedded) TomTom, vv70000-1.1.0 WoWDBProfiler, v BlizRuntimeLib_enUS v7.0.3.70000 (ck=ab8)
  • I don't see that variable or name anywhere in the 7.0 sources for Auc-Util-SimpleAuction
    line 888 in that file is :
    itemID = tonumber(itemID)
    The rest of the line numbers shown also don't match up with what's in svn.

    Try deleting and reinstalling the auctioneer addons. It sounds like you might have somehow mixed an older version with the new release.
  • \AddOns\Auc-Util-SimpleAuction\SimpFrame.lua is not part of the stable Auctioneer Suite release...

    the stable one has this file as
    \AddOns\Auc-Advanced\Modules\Auc-Util-SimpleAuction\SimpFrame.lua

    probably you downloaded some early Auctioneer SVN ZIPs and you did not clear them up properly when upgrading.

    clean up your old addons?
  • I can't even find that variable name in any current addons or Blizzard UI code.
  • Yeah, I was looking that up in our notes. Yep, it definitely comes from older code, not what we have in svn or the 7.0 distribution.
  • I am new to all of this forum stuff, so please forgive me if I am posting my error in the wrong section. If I did post this in the wrong section please let me know and guide me to where I can post it, but for now I will be putting it here! Hopefully, you guys can help me get the add on error free =3

    Date: 2016-08-20 17:37:17
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ...nterface\AddOns\Auc-Filter-Outlier\OutlierFilter.lua line 37:
    Module name outlier already in use by NewModule
    Debug:
    [C]: error()
    Auc-Advanced\CoreUtil.lua:619: NewModule()
    ...nterface\AddOns\Auc-Filter-Outlier\OutlierFilter.lua:37: in main chunk
    Locals:
    (*temporary) = "Module name outlier already in use by NewModule"

    AddOns:
    Swatter, v7.0.5664 (TasmanianThylacine)
    AucAdvanced, v7.0.5664 (TasmanianThylacine)
    AucDb, v5.1.DEV.3583
    AucFilterBasic, v7.0.5664 (TasmanianThylacine)
    AucFilterOutlier, v7.0.5664.5459(7.0/embedded)
    AucMatchUndercut, v7.0.5664.5585(7.0/embedded)
    AucStatSales, v7.0.5664.5598(7.0/embedded)
    AucStatWOWEcon, v7.0.5664.5613(7.0/embedded)
    AucUtilAHWindowControl, v7.0.5664.5575(7.0/embedded)
    AucUtilAppraiser, v7.0.5664.5653(7.0/embedded)
    AucUtilAskPrice, v7.0.5664.5599(7.0/embedded)
    AucUtilAutoMagic, v7.0.5664.5587(7.0/embedded)
    AucUtilCompactUI, v7.0.5664.5629(7.0/embedded)
    AucUtilEasyBuyout, v7.0.5664.5576(7.0/embedded)
    AucUtilItemSuggest, v7.0.5664.5651(7.0/embedded)
    AucUtilPriceLevel, v7.0.5664.5633(7.0/embedded)
    AucUtilScanButton, v7.0.5664.5631(7.0/embedded)
    AucUtilScanFinish, v7.0.5664.5588(7.0/embedded)
    AucUtilScanProgress, v7.0.5664.4979(7.0/embedded)
    AucUtilScanStart, v7.0.5664.5347(7.0/embedded)
    AucUtilSearchUI, v7.0.5664.5657(7.0/embedded)
    AucUtilSimpleAuction, v7.0.5664.5654(7.0/embedded)
    AucUtilVendMarkup, v7.0.5664.4828(7.0/embedded)
    Babylonian, v5.1.DEV.332(/embedded)
    Configator, v5.1.DEV.406(/embedded)
    DebugLib, v5.1.DEV.337(/embedded)
    LibExtraTip, v5.12.DEV.409(/embedded)
    SlideBar, v7.0.5664 (TasmanianThylacine)
    Stubby, v7.0.5664 (TasmanianThylacine)
    TipHelper, v5.12.DEV.405(/embedded)
    BlizRuntimeLib_enUS v7.0.3.70000
    (ck=58b)

  • I have bugs all the way from id1 to id 20 idk how these bugs work if im suppose to post each id or not but I will wait for any feedback to what i should be doing thank and sorry again if I have posted this in the wrong spot
  • grab the zip archive of AuctioneerSuite from http://auctioneeraddon.com/dl/

    if you have a folder directly in \AddOns\ that is not in the root of the archive but is somewhere inside a sub-folder from the zip file then it means it's a leftover file that should be deleted

    what you have installed is not even a beta... it was a very early SVN trunk development snapshot from sometime before august 2nd. You should have seen a very LARGE warning when you got the snapshot that it's not designed for normal users, but for developers.

    at this point i think it might be much easier to just wipe all Auc* folders from under \AddOns\ and re-install Auctioneer from curse client. if that doesn't work.. probably you'll have to wipe the AddOns folder and start re-installing addons from scratch
  • Ah, thanks! I went into the folder after deleting, again, from curse and it wasn't removing all the files. I deleted those and it works fine now. I feel kinda silly for not thinking of that before. Thank you XD
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

privacy
norganna's addons network · tf2 warehouse · scrap warehouse · auctioneer addon · gatherer addon · addon forums · rdrct