Scan options - How do I get it back to STOP displaying every item as it scans?
  • I've tried everything I can think of to get the AH Scan button to STOP showing everything in the AH. I think it's that way by default? Personally, I don't see why it is, since no human being can read those scrolling pages of information.

    What I want is to find the way to present only the "Bar" which shows how many auctions have been scanned and the approximate time it will take to complete the scan of the AH. It worked for me for many years but, after each new update to the AH, it reverts back to the useless scrolling of page-after-page (which offers no information at all).
    **How do I do it? And, as a suggestion, can we have -IT- as a "default" instead of the current method?
    I've fiddled back-and-forth with the "Compact UI" option but, it doesn't give me what I want.
  • The default is to show the scan progress, not the pages of auctions scrolling past. Is Auc-Util-ScanProgress installed and enabled for you?
  • happens to me too,

    i remember it was on by default when i installed the fresh Auctioneer for Legion, but i also had deleted all my SavedVariables at pre-patch launch so it installed with default settings.
    after a while of using Auctioneer i disabled the checkboxes for the text scan progress...i usually keep them disabled (and Compact UI too)...

    i tried now to enable both checkboxes for ScanProgress... (show textual progress indicator and leave the text on screen after completion) but items are still scrolling by as they are scanned. I even restarted warcraft, in case it was needed...

    do i have to enable Compact UI for it to work? i prefer to keep Compact UI disabled.
  • update: tried enabling/disabling Compact UI too (and /reload-ing).. no luck there

    BUT the setting "Prevent other modules from changing the display of the browse tab while scanning" from the Compact UI settings is the one needed here and seems to take effect independently of the Compact UI enabled/disabled state.

    Disabling that checkbox allowed the text scan progress to appear again.

    Why is it under Compact UI settings instead of the ScanProgress page?

    or... if it's CompactUI-related... why is its state independent of the main Compact UI checkbox enabled/disabled state?
  • What does all this mean? lol
    What am I supposed to do to solve the issue I (and others) seem to be having?
    Simple step-by-step to configure it properly will be appreciated.
    Note: I'm using the latest release version.
  • 1. under ScanProgress options: enable the 2 options (show textual progress indicator and leave the text on screen after completion)

    2. under Compact UI options: DISABLE "Prevent other modules from changing the display of the browse tab while scanning"
    (yes, if you have the CompactUI disabled, apparently that checkbox setting is still used even when CompactUI is disabled)
  • as a side note.. seems that hiding the items as they scroll by during the scan is a very nice way of avoiding the silly Blizzard LUA error: "\AddOns\Blizzard_AuctionUI\Blizzard_AuctionUI.lua - attempt to index local 'color' (a nil value)"

    After enabling this i finally managed to run a full scan today and did not get that error, not even even once during the scan. I think it's triggered only when the items actually show in a visible list in the Browse window.

    i even ran a full GetAll() scan and did not get any errors either.

    note: I'm not getting lua errors but still getting lots of unresolved entries during scan though.. (5900 unresolved during the full scan and 29565 during the GetAll() scan) - this seems related to the other Blizzard bug about item info returned being nil.

    now.. if i could get TSM to use the same 'hide the items during scan' tactic of avoiding LUA errors, it would be great.
  • A_Tom, thank you for your input. I used it and now everything is working just fine. I did have 2 separate errors when I first made the changes. One was Auctioneer related and the other was a Blizzard error. However, they disappeared after I turned off two other addons. Note: I kept the LUA error files for each of them just in case you may want to look at them. Thanks again for your help! I'm happy now. grin
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

privacy
norganna's addons network · tf2 warehouse · scrap warehouse · auctioneer addon · gatherer addon · addon forums · rdrct