dependency disabled, auc-advanced not listed
  • I've been having this problem with auctioneer since legion launched (I don't remember if it started with the 7.0 patch or actual legion). All of the modules are greyed out with the message "Dependency disabled" and the tooltip indicates the missing dependency is "Auc-Advanced." However there is no "Auc-Advanced" in the list for me to enable--even though there is an "Auc-Advanced" folder in my Interface/Addons folder.

    I've tried uninstalling and reinstalling multiple times both using the curse program and just manually. I've tried clearing my cache folder. I've read through several other similar threads on this forum, but all of them had other problems and their solutions don't apply to me (e.g. I've confirmed I only have one world of warcraft install folder and am using the correct addons folder and that the folders are installed at the correct level and not nested etc.)
  • 1- Make sure WoW is not installed in Program Files or Program Files x86. Move the WoW directory to some other location, such as C:\Games

    2- Delete all the auctioneer files from your addons directory, including the library files.

    3- Reinstall auctioneer from our site or from CG (you may need to update the wow location in CG installer)

    4- Run the launcher manually from the new location where you moved the WoW directory to.

    If you still have problems, start with screenshots of your addons screen in the character selection part of the wow launcher. include the tooltip showing the missing dependency.
  • 1 - It is installed in "C:\World of Warcraft\"

    2 - I used both commands listed in the manual install guide just for good measure:

    rmdir /s !Swatter Auc-Advanced Auc-DB Auc-Filter-Basic Auc-Filter-Outlier Auc-Match-Undercut Auc-ScanData Auc-Stat-BeanCount Auc-Stat-Classic Auc-Stat-Histogram Auc-Stat-iLevel Auc-Stat-Purchased Auc-Stat-Simple Auc-Stat-StdDev Auc-Stat-WoWecon Auc-Util-Appraiser Auc-Util-AskPrice Auc-Util-AutoMagic Auc-Util-CompactUI Auc-Util-EasyBuyout Auc-Util-FixAH Auc-Util-PriceLevel Auc-Util-ScanButton Auc-Util-ScanFinish Auc-Util-ScanProgress Auc-Util-ScanStart Auc-Util-SimpleAuction Auc-Util-VendMarkup Auctioneer Babylonian BeanCounter BottomScanner Configator DebugLib Enchantrix Enchantrix-Barker EnhTooltip Glypher GlypherPost Informant LibExtraTip nTipHelper Stubby SlideBar

    rmdir /s !Swatter SlideBar Gatherer GatherDB_WoWHead Gatherer_HUD

    All of those folders were already removed after uninstalling in Curse.

    3 - I've reinstalled using Curse multiple times already, and my most recent attempt I manually downloaded and installed using the file on this site.

    4 - I just tried running WoW using all three .exe files in C:\World of Warcraft, but none of them made any difference.

    I think I finally figured it out. Enabling "Stubby" seems to fix it. The message saying that the missing dependency is "Auc-Advanced" is very misleading and not helpful at all when there isn't even any "Auc-Advanced" listed.
  • glaukopes, I had a similar issue occur back in pre-patch and the only thing that fixed it (for me) was going through and enabling everything that was connected to Auctioneer. That included Stubby and (for some unknown reason) Auctioneer was enabled (despite the main sub folder just completely vanishing from my addon settings when I updated the addon to run with Legion when they put out a working version at that point).

  • Weird. I think it should tell you that stubby is the missing dependency if you have that disabled, not auc-advanced. I'll have to double check next time I am online.

    Regardless, that behavior is part of blizzard's functionality, not ours, so there's not much we can do about it if it's buggy except let them know and hope they fix it.
  • as a side comment: i'm using the global dependency on stubby as a quick on/off switch before reloading UI when disabling/enabling the entire Auctioneer Suite... and it works just fine for me.
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

privacy
norganna's addons network · tf2 warehouse · scrap warehouse · auctioneer addon · gatherer addon · addon forums · rdrct