Unable to scan AH
  • I don't know if it's because I recently changed servers, but I have been unable to complete a scan of the AH since I transferred. It will work for about 10 seconds and then the progress will stop. I've tried uninstalling and reinstalling the addon too and the problem still persists. My game doesn't hang, and nothing besides the scan stops working as far as I can tell. I'm on Lightbringer-US, if that matters at all.
  • How big is the server? I can't do it on a large server, but I can on a small.
    (I'm in australia and have latency issues as well, which also influences things.)
  • It's listed as a low pop server on the server select screen. I don't think it's a latency issue, as my latency is Home-73ms/World-80ms
  • If it's stopping completely, you should be getting some error. Make sure that Swatter is installed and enabled. You can use /swat autoshow to make sure it pops up errors when it finds them.

    Also check your chat log to see if anything relevant gets printed there.

    Which stage is it stopping at? You should get a progress bar which shows the current stage.

    In Auctioneer's Config there is a tab for Scanner settings. For now, just make sure the Seller names option is turned OFF, as that badly affects scanning.

  • How long did you wait for it to complete?
    On medium to large servers, the AH scan can appear to hang for up to 10 minutes before all the data arrives from the server. After the data arrives, Auctioneer will process it for another 5 minutes or so.
    On smaller servers, it usually completes in a much shorter time (2 minutes for one of my servers).
  • I may just have encountered this: Scan stopped with no progress in the Scanning stage. Moreover, closing the AH did not hide the Scanning bar, or abort the scan as it is supposed to.

    Must be due to not getting one of the expected events, so it's probably a server problem. I'll have to look into hamdling this sort of failure more gracefully.

    It may be related to cross-realm switching, that other people have mentioned, especially if it doesn't recur after logging out and in again.
  • Hi brykrys,
    I've found that if you run away from the auction house a bit and go back then the scan usually reconnects at it's current location.
  • Resumes. That's the word I was trying to remember!
  • Also... I'm not sure abort the scan if the AH window is closed is actually wanted behaviour as sometimes I press the wrong key and accidentally move and the window closes. It's too easy to do.
  • Closing the AH stops the scanning API, or at least it used to.

    Not sure if a GetAll scan can recover from having the AH closed - the slow/paged scans simply reload the last page, but GetAll scans can't do that due to the 15min delay between queries.
  • Nods at brykrys, yeah I don't think the getall scan does it, but a standard scan does. (Sometimes I still can't run GetAll due to high latency on a large server and have to run a 2-3 hour long standard scan, it sucks...)
  • @Kinesia That's called a dinner break :) at least that's what I do when I run a full scan.
    about 2 hours plus like yours.
    I'm just happy it's working again.
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

privacy
norganna's addons network · tf2 warehouse · scrap warehouse · auctioneer addon · gatherer addon · addon forums · rdrct