start up error at Gatherer_NotificationsTooltip
  • Date: 2016-10-26 19:22:12
    ID: 1
    Error occured in: Global
    Count: 1
    Message: [string "Gatherer_NotificationsTooltip:OnLoad"] line 2:
    Usage: Gatherer_NotificationsTooltip:SetPadding(width, height)
    Debug:
    [C]: ?
    [C]: SetPadding()
    [string "*:OnLoad"]:2:
    [string "*:OnLoad"]:1
    Locals:

    AddOns:
    ***
  • I won't be in game any time soon. Can anyone else verify getting this error? If so I will hold off on pushing a new release version until it is fixed.
  • Fixed in svn now. But I was getting errors from Astrolabe too, which still need to be fixed.
  • okie doke. i will hold off then. thanks.
  • what if you drop Astrolabe and use HereBeDragons instead of maintaining Astrolabe?

    it's a common library used by TomTom and HandyNotes and a lot of other addons - and it's regularly updated and as an added bonus you get a reduction in memory usage because of the shared library use.

    https://www.wowace.com/addons/herebedragons/reverse-relationships/
  • I came here to see if the error I just got from Gatherer was reported, and it lookes like it is. I would like to note, also, that I've been getting errors from (I think) TomTom and Lightheaded regarding HereBeDragons. :/ I copied them out, even tho I don't know where to send them. Would you like to see them?

    This is what Swatter reported about Gatherer, btw:

    Date: 2016-10-29 17:32:35
    ID: 1
    Error occured in: Global
    Count: 1
    Message: [string "Gatherer_NotificationsTooltip:OnLoad"] line 2:
    Usage: Gatherer_NotificationsTooltip:SetPadding(width, height)
    Debug:
    [C]: SetPadding()
    [string "*:OnLoad"]:2:
    [string "*:OnLoad"]:1
    Locals:
    (*temporary) = Gatherer_NotificationsTooltip {
    0 =
    updateTooltip = 0.2
    needsReset = true
    }
    (*temporary) = 16

    AddOns: -- REDACTED FOR LENGTH
    BlizRuntimeLib_enUS v7.1.0.70100
    (ck=b7d)

  • install the latest alpha of HereBeDragons as a separate addon, it will fix the errors that come with the old versions of the library that are delivered with those other addons.
    (the new version overrides the old version from those)

    https://www.wowace.com/addons/herebedragons/files/
    (and it's on Curse too)


    also, the reason of the Gatherer lua error above is that SetPadding used to require a single parameter in 7.0.3 and earlier, now in 7.1 it needs 2 parameters.

    http://fisheye.norganna.org/changelog/Gatherer?cs=1167

    in the file AddOns\Gatherer\GatherNotifications.xml
    at line 70, in the OnLoad section, change
    self:SetPadding(16);
    to
    self:SetPadding(16, 0);

    i just happened to remember this because the MasterPlan addon has the same error with SetPadding - same fix applies there too (add a zero parameter) in AddOns\MasterPlan\GarrisonMissions.lua
    line 644 should look like: itip:SetPadding(0, 0)
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

privacy
norganna's addons network · tf2 warehouse · scrap warehouse · auctioneer addon · gatherer addon · addon forums · rdrct