Auctioneer Appraiser not posting Silksand Boots
  • I have 2 of http://www.wowhead.com/item=14418 in my bag. They are visible on the Appraiser tab, with a valid stack size and limit and all, and valid numbers for the buy / bid prices. Clicking the Post Items button gets the sound effect, but they don't get posted. Haven't had this problem with anything else recently (I remember something similar from a few years ago.) Posting the items through the Auctions tab (which looks unmodified from Blizz default) works fine.
  • I know this problem but I haven't been able to fix it. It's rare, but the items it affects vary between characters and change over time. From what I remember it's due to GetAuctionSellItemInfo() not returning the correct totalCount for the item. We fix this manually for battle pets (Which always have this issue), but I tried applying the same fix to other items and it didn't work. I have this happening with many items and I end up just posting them in the normal posting tab, but that's really bad for my money potentially.
  • Wow, that must be mind-bogglingly frustrating. So far it's happened through two cycles of posting what's returned back onto the AH; the last time it happened (and I don't recall if it was pets or what) it didn't even populate numbers into the price list. So far, I'm taking the prices it is suggesting and using them in the Auctions tab, so at least I have something to go on. Assuming, that is, the prices make sense...
  • Try deleting your cache directory.
  • I cleared the cache, unfortunately it doesn't help. It's still happening on the same items. It's different items for each character, but per character it's still the same items.
  • I think people have said that posting one at a time will work. This is what we do for battlepets - if the caller asks to post X battlepets, CorePost converts this into X requests to post 1 battlepet (and requires a confirmation click for each).
  • Hi brykrys, yeah, I tried setting linkType = "battlepet" to fake it, but it didn't like it. I'm trying to debug it again now though... Which function gets called by the Appraiser "Post Items" button? (I tried looking at GetRequest and PostAuctionClick). [Probably better to talk in IRC when you have time!]
  • Oops, was editing my svn copy instead of the interface copy. No wonder I couldn't see anything!
  • Brykrys, we don't know there's a problem until GetAuctionSellItemInfo in LoadAuctionSlot but we need to know in GetRequest
  • Hmmm. Weird development. I now have _some_ battlepets it doesn't work for. Most seem fine. I reinstalled just in case my changes were to blame, but it's still happening. At the moment it's the Sinister Squashling and Truesilver Shafted Arrow. Weirdly they are both seasonal pets. (Though that might be a coincidence). I haven't noticed this happening with battlepets before, but I've made sure I haven't got any changed files left.
  • Ah, ok, they are both use items, not actually caged battlepets at this point, so handled differently.
  • Hmmm. Wondering if some of the special handling for pet cages will work in Beancounter...
  • Unfortunately (or perhaps fortunately?) I don't get this problem - either it affects certain item types that I don't usually post, or it's server related.

    One thing I thought of to try, if you have found an item this always happens to, is to set it to Batch Post and try posting it that way. The timing is slightly different, so would be interesting to see if it worked.



    Another thing would be to override the "NotEnough" test in private.LoadAuctionSlot, either by commenting out that test section, or by always setting
    totalCount = lib.CountAvailableItems(request.sig)
    (not just when itemID == 82800, i.e. caged battlepets).

    Might also need to do the same thing in private.VerifyAuctionSlot.

    Also, should probably stick in some debug code to inspect private.lastUIError in private.StartAuction - note that the current code only checks if private.lastUIError contains a known blocking error, but if an unknown error shows up here it might help work out what is going on.
  • I've had it on all kinds of different things, but only things with stacksize 1.
    Different characters (even on the same server) have different items affected, but for them personally the items don't change.

    I did LoadAuctionSlot a while back and it still raised an error, but that might be because I didn't try VerifyAuctionSlot too.

    Cool, some stuff to work through, thanks.
  • Make a note of what error you're getting, it might help determine at what point the process is failing.

    One issue may be timing: clicking Post Items attempts to load and post the items all during one event.
    It may be that if we load the item into the auction slot and wait long enough, the API will work correctly.
    Of course to post then would need an extra click, but that might be better than having to post items individually.
  • I've gotten to the point where all our wrapping is removed and there's an error that isn't ours, "You do not have enough items".
    Weirdly none of the debug code I put in is triggering.

    I still suspect we need to know it's broken in getRequest so we can list it like we do battlepets instead of the normal way.
  • Ok, there is one workaround I've found so far...
    in getRequest, don't just use the special handling for battlepets, instead use:
    if multiple > 1 and maxSize == 1 then
  • Made some progress today. I have a brute force change that works but needs a lot more "confirmation clicks". Working on a more correct approach, but it doesn't quite work yet.
  • It looks like it's going to take a while to get it working properly sorry. In the meantime, if it's affecting you you can try this. It has some drawbacks, but I personally find it better. In CorePost.lua change the lines to:
    -- if linkType == "battlepet" and multiple > 1 then
    if multiple > 1 and maxSize == 1 then -- xxx brute force

    (The line with -- exists already, you are commenting it out and replacing it. this seems to work for most things for me.)
  • Latest update for testing is:
    (deleted)

    Still really a workaround for Blizzard API giving wrong data...

    http://jira.norganna.org/browse/ADV-718
  • Found a logical error in the previous test version (it would always try to post ALL of the particular item in your bags, instead of the requested number of stacks) - new latest version has been uploaded to SVN now (r5691), which should fix this.
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

privacy
norganna's addons network · tf2 warehouse · scrap warehouse · auctioneer addon · gatherer addon · addon forums · rdrct