Gatherer and 7.3
  • Looks like we'll need a little update on Gatherer... A couple of new zones, a new herb, (Astral Glory).

    Also there are the Fel-Encrusted herb and Fel-Encrusted herb cluster that were not added when they appeared on the Broken Shore. Those 2 herbs are appearing also on Argus.
  • Any ETA on this? Are devs active lately?

    fyi these are the new ID's:

    [1135] = "LEGION_KROKUUN",
    [1170] = "LEGION_MACAREE",
    [1171] = "LEGION_ANTORAN_WASTES",
    [1178] = "LEGION_THE_SEAT_OF_THE_TRIUMVIRATE",
    [1184] = "LEGION_ARGUS",
    [1188] = "LEGION_ANTORUS_THE_BURNING_THRONE"

    Dunno if gatherer needs all 6 or not.
  • Dunno if any dev will update soon so i patch the addon myself in order to use on Argus.

    Added Regions:
    [1184] => Argus
    [1135] => Krokuun
    [1171] => Antoran Wastes
    [1170] => Mac'Aree

    Added Herbs:
    [269278] => Fel-encrusted Herb
    [269887] => Fel-encrusted Herb Cluster
    [272782] => Astral Glory

    Added Mining Nodes:
    [272768] => Empyrium Deposit
    [272778] => Rich Empyrium Deposit
    [272780] => Empyrium Seam

    I've also edited some of the missing translation for Legion nodes.


    If that can be of any help, you'll find my patch version here:
    http://s000.tinyupload.com/?file_id=63994955687844016223
    http://s000.tinyupload.com/?file_id=09901670307447796781
    http://s000.tinyupload.com/?file_id=09275824654029842263

    NB:
    - This is a quick patch adding Argus features, it won't fix any bug.
    - Gatherer won't be flagged as obsolete anymore.
    - I've only tested for my localization but it should be working fine in all following : deDE, enUS, esES, esMX, frFR, itIT, ptBR, ptPT, ruRU. (Wowhead is missing the translation for other ones)
    - Patched files are : Gatherer.toc GatherCategories.lua GatherConstants.lua GatherNodes.lua GatherZoneTokens.lua
  • here are the translations for german:

    Added Regions:
    [1184] => Argus
    [1135] => Krokuun
    [1171] => Die Antorische Ödnis
    [1170] => Mac'Aree

    Added Herbs:
    [269278] => Teufelsverkrustetes Kraut
    [269887] => Teufelsverkrustetes Kräuterbündel
    [272782] => Astralwinde

    Added Mining Nodes:
    [272768] => Empyriumvorkommen
    [272778] => Reiches Empyriumvorkommen
    [272780] => Empyriumflöz
  • I've just noticed that "Fel-encrusted Herb" are different nodes on Broken Shores and Argus. So i've edited my zip and previous message.
    (However I still need to test this modification)
  • Oh well, I'll have to wait... Can't access the files without opening an account. Thanks for the effort though...
  • That's odd because i didn't even need an account to upload the file.

    Anyway, now that i've tested properly it appears i made a mistake with the Fel-encrusted Herb in the last version. This last one should be ok.
    http://s000.tinyupload.com/?file_id=09275824654029842263
  • It's now ok... I found a way to get around the need of opening an account...
  • To complete the work done by Kalgemini... I created herb icons for the new herbs.

    Copy the 3 .blp files to your herb icons directory...

    ....Interface\AddOns\Gatherer\Icons\Herb

    And replace the GatherIcons.lua file with the one in the zip... The 3 lines added are pointing to the new icons.

    The Fel-Encrusted Herb cluster looks a little small because the herb is taller than its width.

    http://s000.tinyupload.com/?file_id=15555878228266115870
  • Thanks y'all. I am traveling at the moment, but will try to get whatever gets uploaded here integrated at some point in the next few days if possible.
  • Great work guys!!! Works for me
  • I have some .blp ready for the mining nodes... I'm still looking for a Rich Empyrium Deposit... A little less easy to find since I don't have a miner among my characters... I could duplicate the regular empyrium deposit... but I don't want to...
  • Good work, Jeehel! Thank you very much! But...new problem. Now I can`t access to config (I get lua error. After that config window appear, but no any options working.). I`m not sure, that that is depending with your fix. But i can`t reconfigure Gatherer. Only 1 my char was properly configured before 7.3.0 for gather herbs and Gatherer works great. All other my chars are looking and crying...
    May be, You can try to investigate that problem?
  • Unfortunately, this error is out my scope... I have it too...

    Date: 2017-09-10 16:43:16
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\Gatherer\GatherConfig.lua line 696:
    attempt to index local 'objType' (a nil value)
    Debug:
    Gatherer\GatherConfig.lua:696: MakeGuiConfig()
    Gatherer\GatherConfig.lua:492: Show()
    Gatherer\GatherReport.lua:146:
    Gatherer\GatherReport.lua:146
    Locals:
    id = 4
    last = {
    0 =
    }
    cont = nil
    Configator = { CreateAnonName = defined @Interface\AddOns\Auc-Advanced\Libs\Configator\Configator.lua:96 TabLink = defined @Interface\AddOns\Auc-Advanced\Libs\Configator\Configator.lua:115 SetTip = defined @Interface\AddOns\Auc-Advanced\Libs\Configator\Configator.lua:262 SetLinkTip = defined @Interface\AddOns\Auc-Advanced\Libs\Configator\Configator.lua:243 frames =
  • There seem to be 3 debug line after line 696 in GatherConfig.lua. I temporarily activated them and it reported this in my chat window :

    "missing data for Rich Empyrium Deposit 272778 Rich Empyrium Deposit nil"
  • Ah ah... I checked the entries for the Rich Empyrium Deposit and I found out that there is a line missing in the file GatherNodes.lua, Currently, lines 2930 and 2931 reads like this :

    [272768] = "MINE", -- Empyrium Deposit
    [272780] = "MINE", -- Empyrium Seam

    Just add a line between those 2... and you will regain access to the config window

    [272768] = "MINE", -- Empyrium Deposit
    [272778] = "MINE", -- Rich Empyrium Deposit
    [272780] = "MINE", -- Empyrium Seam
  • I made that. Error has gone, but no nodes for miners. For herbs all right. And i was comparing all settings between herbalists and miners. All settings are the same (exclude herb and mine profession, of course). Very strange...:(
  • OK... I gave it a go and made a small file update for 7.3.0. It contains all the work made by Kalgemini and me. This is not the whole package for Gatherer. This is only what was either modified or added.

    http://s000.tinyupload.com/?file_id=69501671138674896291


    What it inside :

    From Kalgemini :

    - This is a quick patch adding Argus features, it won't fix any bug.
    - Gatherer won't be flagged as obsolete anymore.
    - I've only tested for my localization but it should be working fine in all following : deDE, enUS, esES, esMX, frFR, itIT, ptBR, ptPT, ruRU. (Wowhead is missing the translation for other ones)
    - Patched files are : Gatherer.toc GatherCategories.lua GatherConstants.lua GatherNodes.lua GatherZoneTokens.lua

    From me :
    - I added one line to Kalgemini works in GatherNodes.lua for the Rich Empyrium Deposit.
    - I added .blp files for the new herbs and mining nodes.
    - I modified GatherIcons.lua to add the links to those .blp files.
    - Playsound command now requires a value instead of a string. There was 2 files that contained Playsound with the old string. I updated the commands with the necessary 2 values.

    In GatherConfig.lua, the playsound now reads : PlaySound(SOUNDKIT.IG_QUEST_LOG_ABANDON_QUEST);

    and

    in \libs\Configator\SelectBox.lua, the playsound now reads : PlaySound(SOUNDKIT.IG_MAINMENU_OPTION_CHECKBOX_ON)

    That should be all.
  • Hi again. I was making all what you say. I want to tell about results.
    1. All work fine on old (7.2.5) locations for both professions (herb and miners), without any errors. Herbs and ores collected and marked well on map, minimap and database for searching nodes.
    2. On Argus locations work nodes for herbalists only (Herbs nodes collected and marked well on map, minimap and database for searching nodes).
    3. On Argus locations NOT works for ore nodes at all. No any nodes icons on map, minimap or database ( I was checking my miner on Broken Shore locations without any settings changes and all working fine). I was trying to disable all other addons and check Gatherer... No luck. All the same. I have no ideas, what is wrong...:( The last chance, that something wrong with locales? (I`m playing on ruRU servers)
    P.S. Hope for you only...
  • Hmmm... I don't have any miner to test it... So I assumed that herbs and ore should be marked the same way on the map and mini-map. I'll try to see if I can find something on this. It's rather easy to add zones, names and nodes but the programming of the addon itself is another ballpark... But I'll try nonetheless...
  • OK... Even though I don't own a miner... I made around a dozen of unskilled gathers with some mining nodes and they are all showing for me on my map. English locale for me...

    http://s000.tinyupload.com/?file_id=84589160697642014324
    Image of the nodes
  • Sfairat, as you said it might be a locale issue. Feel free to post here ruRU translation for the ore nodes as they appear in-game.
  • A huge "Thank You" to both of you for your work on this. I can't test it directly yet as my characters that use this addon can't access Argus yet (my only level 110 char atm is my warlock, who's a tailor/enchanter) but it is nice to not get that "zone not recognized" error message every time I login.
  • Jeehell, thank you very much for your screenshot. I`ll search, what is wrong with ruru localization.
  • I have used your files above to drycode a new build, version 7.3.0, available here: http://gathereraddon.com/dl/

    Before I announce it, can someone download it and test it? I will not be at a machine that can launch WoW, and won't be for a few days, so hopefully someone else can do it and make sure things seem to be working.

    Thanks again to Kalgemini and Jeehell!
  • Saved my gatherer directory... Deleted it and replaced it with your build... All is fine on my side...
  • Replace my directory as well and no fatal error.
    However, a "Rich empyrium deposit" node didn't saved. Probably a locale issue if capital letters count.

    => in frFR, try replacing the capital on the second word.

    NB: Not a big fan of the Empyrium Seam icon. It's too tiny and hard to see on the map.
  • I made the frFR change and packaged a new release. If someone wants to update the blp file, please do and I'll include it in the next package.
  • For the Empyrium Seam icon... you can just make it point to the regular Empyrium Deposit icon in GatherIcons.lua for the time being.

    [272780] = "Mine\\EmpyriumSeam", -- Empyrium Seam
    to
    [272780] = "Mine\\EmpyriumDeposit", -- Empyrium Seam


    The problem with this icon is how the seam appears in-game. I made the icon from a screenshot. The problem with the seam is because it is so much wider than it is tall that it is making a very wide rectangle. When trying to fit that "rectangle" in a 64 x 64 pixels (square) .blp file... it makes it look very small. I could probably make it look a little better if I crop the image a little to reduce the rectangular effect. I was trying to remain as close as I could to the real image

    The same phenomena happens with the Fel-encrusted Herb Cluster which in this case is much taller than wide.
  • Hi, here is the missing 7.3 node strings for zhTW.

    ["魔覆草藥"] = 269278, --
    ["魔覆草藥簇"] = 269887, --
    ["暗星之芒"] = 272782, --

    ["燦鐵礦床"] = 272768, -- Empyrium Deposit
    ["豐沃的燦鐵礦床"] = 272778, -- Rich Empyrium Deposit
    ["燦鐵礦層"] = 272780, -- Empyrium Seam

    Taken from the locale data from Gathermate2, since I can only confirms about these 7.3 mining node strings do working and I hope herb ones working too... :)
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

privacy
norganna's addons network · tf2 warehouse · scrap warehouse · auctioneer addon · gatherer addon · addon forums · rdrct